Quick Start

One page summary of how to install the agda-algebras library.

Requirements

Before using the library, you need to install Agda ≥ 2.6.2, and the Agda Standard Library ≥ 1.7.

Installing Agda and the Agda Standard Library

Agda (version 2.6.2 or greater) is required. If you don't have it, follow the official Agda installation instructions.

For reference, the following is a list of commands that should Agda version 2.6.2 on a Linux machine (with Ubuntu 20.04, e.g.). If problems arise when attempting to follow these steps, please email the development team or submit a new issue to the git repo.

cabal update
git clone [email protected]:agda/agda.git
cd agda
git checkout release-2.6.2
cabal install Agda-2.6.2 --program-suffix=-2.6.2  # (takes a very long time)
cd ~/.cabal/bin/
touch ~/.emacs
cp ~/.emacs ~/.emacs.backup
./agda-mode-2.6.2 setup
./agda-mode-2.6.2 compile
mkdir -p ~/bin
cp ~/.emacs ~/bin
cp ~/.emacs.backup ~/.emacs
cd ~/bin
echo '#!/bin/bash' > agdamacs
echo 'PATH=~/.cabal/bin:$PATH emacs --no-init-file --load ~/bin/.emacs \[email protected]' >> agdamacs
chmod +x agdamacs
echo 'export PATH=~/bin:~/.cabal/bin:$PATH' >> ~/.profile

Now invoking the command agdamacs will launch emacs with Agda 2.6.2 and agda-mode installed.)